Release notes for:
NCG CAM v15.0.05
Date: 16/08/2017

NCG CAM Solutions Ltd are pleased to release NCG CAM v15.0.05
This point release includes minor updates and little fixes we have made since v15.0.04. We would suggest
you update to v15.0.05 at the earliest convenience.
Please note that NCG CAM v15.0 will not install on Window XP, or on a 32 bit operating system.
Windows 7, 64 bit, Windows 8 / 8.1 64 bit or Windows 10 64 bit are all supported operating systems.
V15.0.05

1192 : Surface Analysis: You can now specify the colours that represent out of range values for the surface
analysis functions (ie Curvatures, Compare Surfaces, and Draft Angles).
Go to the Tools > Options > System Colours and the buttons are in the Analysis group.

3707 : Improvements to the surface comparison: When positioning the cursor over the point on the surface,
a negative value of surface offset will be displayed if the point is inside the surface. This could make the
surface comparison feature more usable when making electrodes.
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3752 : User interface: Improved guides for extend / trim curves. We now draw an arrow (in the same
direction as the curve) to show the new end of an extended curve. If the curve is trimmed away we show a
red blob on the shortened side.

4219 : User interface: Drilling cycle warning message boxes now indicate the severity of the warning by
having a headline "Warning" in black, or "Danger" in red above the message.

4656 : Points: Midpoint now works on a surfaces plan, or a sub-selection of surfaces. The returned point is
positioned in the centre of the XYZ region defined by the surfaces.
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4893 : Points: A new option "Convert to Points" has been added to the Points menu. When a single detect
holes plan or drilling data plan is highlighted, this option can be used to extract the hole centres as a point
tessellation plan.

4958 : Linking: Transform Reverse Linking with boundary passes now reverses and relinks.
4979 : Split ToolPath: A performance problem associated with recalculating shaft profile data while running
split toolpath (or sister tooling) has been fixed.
4996 : UV Machining: Improve pass spacing at joints between surfaces when machining fillet where the
passes are perpendicular to the fillet.
5024 : Provided Reset to System Defaults under the mouse right context menus for pages on the tools
options dialog. Each menu has "This Page" and "All Pages" options.

5029 : User Interface: Fixed a problem selecting surfaces in the User Interface from a transformed surfaces
plan.
5035 : User Interface: Provided a warning dialog rather than exception when attempting to write a file with
strange characters in the project prefix.
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5037 : Shaft Profile: The Shaft Profile Analysis dialog now allows compatible tools to be load from the Most
recently used cutter list, the tool used will now also be added to the MRU cutter list.

5040 : The default value for bParallelEnabled is now false in the post processors. Performance of post
processing on i7s is improved by around a factor of 2 by setting this value true, but on Xeons the
performance is worsened by about 2.5 by setting it true. Since the performance of post processing on Xeons
is about 2 times worse than on equivalent i7s, the loss is worse than the gain.
5041 : Shaft Profile: It is now possible to output the Shaft Profile results to a Java Script file (*.json).
5043 : User interface: The transforming of surfaces with a repeat count was not adding the combined surface
folder to the tree view, this has now been fixed.
5044 : Five-Axis: There are occasions when using under-cut style cutters (LolliPop, T-Slot and Dovetail) that
collisions were being flagged incorrectly, this was due to the tool being projected to infinity, this has now
been switched off for under-cut style cutters (5 axis console > Gouge check > Advanced).

For LolliPop, T-Slot and Dovetail, this option wants to be unticked, and is now by default for these cutters.
5047 : Adaptive Clearance: The validation of the Stock Clearance parameter was incorrect allowing invalid
input to the plan, causing a failure, this has now been fixed.
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5048 : Post processor: Heidenhain: Added the option to verify the tool length (options already existed for the
cutter diameter and corner radius). The new parameters are:
Verification includes tool length (set false by default so exiting post processor are not affected).
Tool Length Q Function for the Q-value that takes the tool length.
Tool Length Q Suffix, which is used to call the relevant sub program on the machine.
There is also a Max toolholder diameter parameter, diameters above this are ignored.

5049 : Machining: The use of a zero length flute for machining causes the simulation application to hang. We
shouldn't really allow zero flute lengths so it is now not permitted.
5050 : Linking: A problem with the linking of rest roughing passes which was causing it to take excessively
long in some special cases has been fixed.
5054 : User interface: If you pasted text into the Project Settings or Cutting Parameters ‘Comment’ fields,
there were occasions when this text would be ignored, this has now been fixed.
5056 : User interface: If you transformed more than one folder at a time and they were of different types (i.e
one surface and one curve folder) the resulting folders although had the correct names were not the correct
type inside the database. This has now been fixed, it also fixes ticket 5057.
5060 : Editing a toolpath to stock model: A problem has been fixed where a program crash occurred when
editing passes to a stock model that was created from a set of triangulated surface.
5062 : Helical Passes: Modified the default setup of boundaries to limit the chance of producing passes
outside of the drive boundary.
5070 : Inspection: We now support output for the Heidenhain 640 control in addition to the already supported
Heidenhain 530 control. The default control is the 530

5079 : Machine Along Curve: A problem when machining curves containing horizontal arcs in 3+2 has been
fixed. This also fixes ticket 4982
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5084 : Updated the CatiaV5 reader to V2017.2. This provides support for CatiaV5 R2017 (R27).

5086 : User Interface: The Custom View dialog is now resizable, to allow for changes in windows display
options, so fields do not get truncated.
5090 : Post processor: ISO post: Added the option to allow a tool to be probed at the end of a toolpath only.
In the post processor options for the tool probing, the option "Only probe the end of toolpath" has been
added, the default is false so not to affect existing post processors.

5091 : Updated GPOST to V6.7 P17
5093 : User Interface: The user now just gets a warning in the log window when a drilling macro fails to find
the required drilling data, rather than a popup dialog. Large generic macros were creating an unreasonable
number of popups. Added a paragraph about drilling macros to the Macros page in the documentation.
5094 : Shaft Profile: Improvements have been made to the handling of thicknesses. The shaft profile data is
now built without adjustment for thickness. Also fixes an update problem with rerunning shaft profile with a
tool selected from the database has been modified.
5095 : Inspection: It is now possible to define a holder (probe body) clearance distance when creating
Inspection vectors.

5096 : Linking: Core roughing passes. Fixed behavioural inconsistency between edited and unedited passes.
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5112 : Five-Axis: If you use a Five-Axis plan to create a 3-Axis toolpath with an Under-Cut style cutters
(Lollipop, Dove or T-Slot) the primary gouge protection strategy will now default to 'Leave out gouging points'
instead of 'Retract along tool axis'.
As the cutter could be in an undercut position, retracting along the tool axis could be dangerous.
5118 : Macros: When running a macro with 'Display All Dialogs' we now honour the 'Allow Empty Toolpaths'
setting when displaying the Post Processor dialog to stop any unwanted message dialogs appearing.
5120 : Corrected a problem where if outputting the NC file in microns, a comment that should show the
decimal value, was also in microns. Also fixed an instance where microns were incorrect.
5124 : Fixed a case where re-running dependent plans (in this case on a cutting parameters plan) that could
cause the database to lock up.
5125 : Post Processor: ISO post: The incorrect machining tolerance was being used by the post-processors
and toolsheet macros for Five-Axis plans for the linearisation of arcs, this has now been fixed.
5135 : Adaptive Clearance: A new option has been added to the Adaptive Clearance strategy to enable
Vertical arc linking moves.

5136 : Updated the translation dll’s for the ModuleWorks 2017-04 Libraries – fixes ticket 5151 also.
5137 : User Interface: The creation of Pre/Post bin files for Five-Axis plans was not always working correctly,
this has now been fixed.
5147 : Rest finishing: A possible gouge that could occur in steep sections of toolpath has been fixed.
5152 : Tool Database: Tool Databases the reference a cutter / holder in a deleted tool database are now
highlighted in red in the options dialogue, with an indication to the missing tool database name. These tool
databases cannot be used until the missing catalogue is included in the list.
5159 : Menu item "Draft Angles" can be selected on context menu for triangulated surfaces.
5162 : Surface Analysis: You can now alter the upper and lower limits to any numeric values in analysis
dialog without receiving any error messages.
5166 : Import: Updated the Parasolid reader to v30.0
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5167 : User Interface: The File > Macro > Save As... dialog has been tidied up. This also fixes ticket 4986
5171 : Trapped exception that could be thrown when creating a stock model from a set of plans one of which
had failed.
5174 : User Interface: When tutorial and reference manuals are accessed from the Help menu they will now
remain in view if the user clicks on another NCGCAM window, rather than being obscured by it
5175 : Shaft Profile: Fixed a problem causing Required Cylindrical and Required Body Lengths to be
incorrect.
5178 : Tool Database: It was possible to create multiple tool database entries pointing to the same tool library
output file. This is now checked for and disallowed.
5179 : Surface Analysis: An error message box will appear when you change the upper or lower limits to
invalid numbers in the surface analysis dialog for curvature, draft angles and surface comparison.
5180 : Export to Excel: The exporting of data to excel spreadsheets is now forced to have the English style
(dot) decimal delimiter.
5181 : Tool Database: It was a problem that if you added an existing tool database to your loaded list, but
changed the description name from the original, then you would lose your holders from any tools. This has
now been fixed.
5182 : User Interface: Shaft Profile Analysis: We no longer force gouging sections of the profile to be drawn
in solid colour. Instead we use the user defined translucency on the Tools > Options > System Colours page.
The Default colour Shaft profile(Gouges) has been made more opaque.

5183 : Shaft Profile: The Shaft Profile can be enabled from the machining passes plans again.
5187 : User Interface: There were occasions when the focus was not being set correctly after dialogs have
been deleted, this has now been fixed.
5189 : Surface Analysis: The lower limit for a surface comparison is initialised with the smallest negative
thickness in the stock model used in the comparison, or 0 otherwise.
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5191 : User Interface: A new option has been added to the dialog context menu to copy the parameters from
the tool pages to the clipboard for pasting.
5193 : Macros: The User variable comments were not being set correctly when running a macro using
variables, this has now been fixed.
5195 : Adaptive Clearance: If a boundary was included in the plan, and the boundary was a meta plan, then
the rotations would not be used for the toolpath calculations. This problem has now been fixed.
5209 : User Interface: Fixed a problem where resizing Cutter Page reset Body Length and Shank Definition
parameters
5210 : User Interface: A check box was out of line on the Tools > Options > General page, this has now been
fixed.
5211 : Shaft Profile Analysis: We can't allow shaft profile analysis of roughing style passes to change the
cutter as the shaft profile calculation is not stock safe.
5214 : Shaft Profile Analysis: A validation check has been added to make sure the flute length cannot be
reduced (even for zero taper angles)
5223 : User Interface : It was possible when copying parameters with the context menu within a Five-Axis
plan dialog for NCGCAM to crash, this has now been fixed.

Updated What's New for 15.0.05. This also fixes #5003
Documentation for the improvements made to the handling of thickness for Shaft Profile.
Made corrections to the tutorial.
Updated the English EULA wording to refer to using as well as installing the software.
Updated the German, Portuguese, Japanese Revo translation.
Removed accelerators from the dialogs in the Chinese Simplified, Chinese Traditional, French, Hungarian,
Italian, Korean, Spanish, Polish, Portuguese, Brazilian, Russian, Thai and Turkish translations.
Updated the German help files.
Corrected dialog layouts in all translations, and removed unwanted blank lines from the translations.
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