Release notes for:
NCG CAM v15.0.03
Date: 12/01/2017

NCG CAM Solutions Ltd are pleased to release NCG CAM v15.0.03
There are some new features, enhancements to existing features, and some problems fixed.
Please note that NCG CAM v15.0 will not install on Window XP, or on a 32 bit operating system.
Windows 7, 64 bit, Windows 8 / 8.1 64 bit and Windows 10 64 bit are all supported operating systems.

1191 : User Interface: The Analysis dialogs, Curvature, Draft and Surface Comparison now have a ? (help)
option.

2119 and 4812 : New feature: Post Processor: An option has been added to allow multiple selected
toolpaths to be post-processed into separate files. This just required the ‘Post to individual files’ option to be
ticked (it is unticked by default).
If using the ‘Post to individual files’ option, it is then possible to group or join adjacent toolpaths that use the
same tool number in consecutive toolpaths.

If using this feature, and the specified NC file is “job_2461_nc5”, the suffix _01, _02, _03… will be added to
the file name, giving: job_2461_nc5_01.nc, job_2461_nc5_02.nc, job_2461_nc5_03.nc,
4285 : User Interface: The Ruler display on the Tool Page was not handling Shaft Profile data correctly, this
has now been fixed.
4295 : Added new option "Use input geometry" to the "Save as Macro" dialog as an alternative to "Surface
independent". Selecting this option adds the ability to generate planar patches and fillets in surface
independent macros.
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3106 : Drilling data now uses the actual rotation input to a detect holes plan if this is set. This allows a
boundary with A 0 B 0 C 180 to force a half turn when used as input to detected holes.
This can be helpful on some 5 axis machines, when it is preferable to rotate C180 than reach all the way
across the part.
4387 : Shaft Profile Analysis: Modifications made to the tool in the shaft profile analysis dialog are now saved
in the database in a new plan. Hence performing a ‘properties’ on the Shaft profile plan will not show the tool
holder and cutter shank details. Subsequent operations will use the updated tool (from the shaft profile
dialog). Improvements have been made to the Required Body Length and Required Cylindrical Length
Calculations. The display of shaft profile data during animation has been improved too.

Above, Properties on a shaft profile shows the holder and cutter shank that was defined.

The toolsheet will display the cutter shank and holder details from the shaft profile.
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Also fixes :–
1067 Post Processor: Shaft profile / body length.
1824 Shaft Profile: Passes have cutter and holder.
2457 Shaft Profile: Tool database: Allow non tapered cutters with of longer flute lengths to be picked.
2562 Toolsheet: Add required cylindrical length to tool sheet.
3733 Shaft profile: Redisplay holder once a holder has been fitted.
3963 Toolsheet: The Shaft profile tool holder now displayed on the tool sheet.
3962 Toolsheet: Required body length is now shown.
4689 Cutter Animation: View shaft profile holder option.
4745 Shaft Profile: Issues with required lengths have been fixed.
4807 Documentation: Changes to reflect saveable shaft profile analysis plans.
4809 Shaft Profile: Animation Improvements.
4811 Shaft Profile: Wording in dialog.
4501 : Fixed a crash that could happen when loading a database from a future version.
4635 : User Interface: The XY & Z thickness parameters are now available on the Five-Axis Passes page.

4535 : Drilling: There were some examples where gouges were incorrectly being detected when Bore Milling,
this has now been fixed.
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4636 : Drilling macros will now run even when there is no drilling data to match all the data in the macro. A
warning box is shown for each drilling data that is not found, and for each empty cycle that is produced as a
result. The empty cycles will show as failed and should be removed by the user. However, the rest of the
macro will run to completion and will not abort just because some drilling data is missing.
4709 : To allow the NC file to be output in microns, some additional options have been added to the ISO post
processor:
'Crop trailing zeros: comments' default = false,
'Retain decimal separator: comments' default: mm = false / inches = true,
'Decimal separator: comments' default = . (dot),
'Output XYZ moves as microns' default = false.
The default settings should leave existing posts as they are.

4716 : Performance: There were occasions when post processing over a network would be very slow, this
has now been fixed.
4735 : Orphaned boundary plans are no longer cancelled. A dummy boundary plan is created when running
a macro and if this was not used it was cancelled, which could cause confusion if the macro was started
paused.
4748 : Cutter animation: When animating the Shaft Profile we now only draw one ring per ‘Slice height’,
defined in the Shaft Profile settings.
4750 : Fixed a problem causing constant stepover passes to fail when generated from along curve passes.
4755 : Post processor: the ISO and Heidenhain: Added a string for the motions limits comment, “Motion
limits header” the default is still “Motion Limits”, but can be changed if needed.
Also added “Motion limits footer” which is blank by default, to be in keeping with some other options like the
tool list.

This means those comments can be translated to the local language.
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4763 : User Interface: It was possible to create a ToolHolder or Body definition which had a flat disc on the
top, which is not valid, this has now been trapped and the plan will not run.
4764 : User Interface: The icon for Adaptive Clearance has been modified to indicate it is a linked toolpath.

4765 : Five Axis: The Start Hint for Five Axis plans is now on the Linking page instead of the Passes page for
consistency with all other plans, there is now also an option to disable the start hint.

4767 : Import: Reading with Granite can fail if we first look at the Help > About NCGCAM > Translators page,
this has now been fixed.
4772 : Import: Updated the Catia reader libraries to V2016.4.
4773 : Import: Updated to Parasolid v29.1

4780 : User Interface: Fixed a problem which meant that the guide curve for machine along curve passes
was drawn wrong when machining in 3+2.
4782 : Adaptive Clearance: It is now possible to include a Points Folder when creating the toolpath to define
pre-drilled points for plunging.
4783 : Adaptive Clearance: A Rapid retract option has been added to the Linking page.

It is checked by default, so to retract in rapid, it is possible to retract at the federate, which is what was the
original action in v15.0.02
4784 : User Interface: It is now possible to use the Ctrl+Shift+X/Y/Z keys to set the view from the rotations of
a DrillingDataTopFolder., like it is possible with a 3+2 toolpath or 3+2 boundary.
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4786 : SolidWorks assemblies which contain no geometry no longer fail when loading, but instead give a
warning.
4788 : Rest finishing: A fix has been made to prevent a gouge that could occur for on-surface spiral
connections of shallow passes.
4795 : User Interface: Fixed a problem when running Geometry > Analyse on fillet surfaces.
4796 : User Interface: The “X” button has been added to the Toolpath analysis & File > Properties dialogs.
4802 : Post processors: Heidenhain: Added the options – “Output the boring spindle orientate angle” by
default this is set ‘False’, Boring spindle orientation angle prefix, which is Q336 by default. Angle for boring
spindle orientation, which is the angle for the spindle to orientate too, the default is 0.
These are only available when boring with spindle orientation.

4804 : Five-Axis Roughing: It is now possible to constrain a Five-Axis Roughing toolpath within a 3D
constraint curve by including the selection of a Curves Folder.
4808 : User Interface: The Toolpath Analysis dialog pages for the frequency graphs were not always
displaying the correct data, this has now been fixed.
4818 : User Interface: Corrected the appearance of the first two user definable colours in the Tools > Options
> Entity Colours dialog page.

4827 : Provided support for SolidWorks 2017 part files

4830 : Post Processor: If you do a properties on a post processor plan and then modify the cutting
parameters plan via the toolpath page, it was not using the new cutting parameters when post processing,
this has now been fixed.
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4846 : If the user changes the location of the program data folder then the Most recently used (MRU) cutter
file is now moved to that new location, and its location is updated in the registry.
4847 : User Interface: The option to “Preserve Root folders” has been moved from the Modifier dialog onto
the Plan dialogs where relevant. The Shift key can still be used to set the default when activating the dialog.

Setting the cutting parameters
Post processing
If this option is enabled, the root folders will remain at the top level of the contents tree, but in most cases, it
is not necessary to do so.
4853 : User Interface: When the inputs were changed in a dialog using the plan input page the plan label
was not always being updated correctly this has now been fixed.
4854 : New feature: User Interface: An option has been added to the toolpath verification page when post
processing to allow the estimated machining time to be obtained for all toolpaths, for a set of selected
toolpaths, or for a specific tool number. The default is “All” so the estimated time is for all tools, as it was
before.

Mini guide.
With All selected, the estimated
time is for all the toolpaths.

Release notes for:
NCG CAM v15.0.03
Date: 12/01/2017

Clicking on the tool number list, it is
the possible to select an individual
tool number. The list will only show
tools used in the toolpaths being
post processes.
The estimated time shown now is
for all toolpaths that use that tool
number.

By selecting “Selected” from the
list, it is then possible to select
groups of toolpaths, and the
estimated time show is for the
selected toolpaths.

This can be very useful when you have a lot of toolpaths using the same tool number, it makes it easy to
check the cutting time for a particular tool or selected toolpaths, then if it is too long, some toolpaths can be
changed to a different tool number.
4855 : Post Processor: Heidenhain: If using a Q-value for the spindle speed, it was possible for the first
operation to not have the correct value (speed) - this has been fixed.
4856 : User Interface: There were occasions where trying to combine two boundary folders with the same
rotations would not be permitted, this has now been fixed.
4862 : Detect Holes: There were occasions when composite holes were detected and generated outside of
the holes depth, this has now been fixed.
4865 : User Interface: Transformed Shaft Profile Analysis Plans are now named after the input toolpath ie
'Transformed Raster Toolpath 1 [20x3.5, 0]' not 'Transformed Shaft Profile Analysis 1 [20x3.5, 0]'.
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4866 : Rest finishing: A problem has been fixed where a significant gap in the rest passes could appear in
the vicinity of a multi-way corner where steep passes met shallow passes.
v15.0.02 Rest finishing passes, shallow area connections.

v15.0.03 Rest finishing passes, shallow area connections.

4867 : User Interface: When the Program Data Folder is changed in Tools > Options > General we need to
update the machsim.ini file to use the new path for current.keymap. A warning is now issued for Five-Axis
users that it needs updating.
Using Windows Explorer, browse to your Program Data Folder (as set in Tools > Options > General)
Go to the MachineToolDefinitions folder.
Locate the file: machsim.ini
Open that in a text editor such as: notepad
Find the line that starts: defkeyfilename=
By default it will continue with: %ProgramData%\NCGCAM Solutions\Machinetooldefinitions\current.keymap
Chance that to be the same location as defined in Tools > Options > General for the Program Data Folder
Save the file.
It is important not to change anything else. If you are unsure, speak to your reseller.
4868 : Import: Updated Granite to v10.0 F000. This provides support for Creo 4.0.

4870 : Machining: The use of selected surfaces for Radial/Spiral & Perpendicular Raster passes was broken,
this has now been fixed.
4876 : Fixed exception thrown when drawing and undrawing an animated toolpath.
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4877 : User Interface: When Post processing a large number of toolpaths there were occasions when there
was quite a delay before the dialog was displayed, this has been improved and is at least twice as fast now.
4878 : Rest finishing: The quality of rest finishing passes joining for shallow sections has been improved.
4880 : Improved the cleaning up of temporary files.
4883 : User Interface: The Cutter Animation, Process Manager, Tool Guide, Machining Simulation & Analysis
dialogs are now consistent with other dialogs in there format regarding the X close button in the top right
corner, a ? (Help) button has also been added.
4885 : User Interface: The wording on Linking pages of dialogs for Start Hint has been made consistent and
in-line with the home point across all dialogs.

Start hint appearance for a 3 axis toolpath.

Start hint appearance for a 5 axis toolpath.

4888 : Post processor: Heidenhain: It was possible for a "~" (tilde) to be output on the last Q-value for a bore
milling cycle, when the last Q-value does not need it. This has been fixed.
4890 : Drilling : The rotations are now checked when using multiple drilling data plans when creating a cycle,
and a warning that the first rotation will be used is given if they are different. If the tool axes are different,
then the cycle plan will fail as before.

Documentation: Updated, including the tutorial and the What's New for 15.0.03
Updated the Turkish translation.
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